Susyを使おうとしたらNo such framework: “susy”のエラー

レスポンシブグリッドレイアウトが組めるSass/Compassベースのフレームワーク「Susy」を使おうとしたところ「No such framework: “susy”」というエラーが発生。Susyプロジェクトを作成するコマンドを打つと出てきました。

こんなやつですね。それで、このエラーは自分の場合Gem、Sass、Compassのバージョンを上げると解決しました。

アップデート方法は探せば各所で見つかりますが、ついでなので以下に書いておきます。

Sass,Compassをアップデートする

まず、gemのアップデートを先にしておきましょう。 もし最新版なら「Latest version currently installed. Aborting.」と出ます。

次にSassのアップデートです。

最後にCompassのアップデートです。

 Sass,Compassのバージョン確認

私がSusyのプロジェクト作成に成功したバージョンはこちらです。

  • gem ( 2.4.1 )
  • Sass ( 3.4.3 )
  • Compass ( 1.0.1 )

それぞれのバージョン確認は

で行えるので、ご参考までに。

最終更新日:2014年9月28日

コメント

「何かそこ違うよ」「こうした方が良い」っていう部分があったら指摘して頂けると嬉しいです。

トラックバック

トラックバックは現在ありません。

Trackback: https://increment-log.com/susy-start-error/trackback/